N2WS-17820 - Volume DR fails with TypeError: %d format: a number is required, not str

N2WS-17820 - Volume DR fails with TypeError: %d format: a number is required, not str

Issue:

When doing cross region DR, it might fail with following error in the cpm_dr logs:

2021-03-02 00:13:04,123:[140450227709760] ERROR: dr_function(dr.py:164) DR function encountered an exception
Traceback (most recent call last):
...

...
TypeError: %d format: a number is required, not str



Solution:
Patch for v3.2.1 Available and attached to this KB


Click here to go back to the Release notes: Release notes for the latest v3.2.x CPM release

    • Related Articles

    • DR may fail due to the “Volume DR Failed getting volumes info” and “RequestLimitExceeded” errors

      If DR fails with the below errors in Backup log ERROR: check_region_copy_state(.\cpmserver\cpm\dr_volume.py:<line_number>) Volume DR Failed getting volumes info in region <Region name> (policy <Policy Name>,in Backup account), Exception: ...
    • How to upgrade CPM using a patch

      Please note: upgrading using patch does not upgrade Apache General: 1. It is recommended to deploy the patch when you have no active backup policies, DR or recovery running - as it will restart Apache and require few min downtime. 2. When using ...
    • DR of encrypted snapshots may fail with the “No matching KMS alias” error

      DR of encrypted snapshots may fail with the following error in the Backup log: ERROR:  start_copy_region(.\cpmserver\cpm\dr_volume.py:<line number>)  Volume DR copy snapshot failed (in Backup account). No matching KMS alias on target region (source ...
    • Patch for cost reduction of copy to S3

      Installation of the patch will reduce costs drastically for customers who are using S3 (Between 5 to 20 times less expensive than previous version) The improvements are: For copied volumes which are larger than 512GB, worker’s volume type will be sc1 ...
    • Release notes for the latest v3.2.x CPM release

      In order to upgrade to version 3.2.x from 2.4.x/2.5.x/2.6.x , please see the instructions here: https://support.n2ws.com/portal/kb/articles/upgrade-instructions-for-v3-x In addition, If you are using VSS Agents, after the latest version is installed, ...